自动安装与模组下载简介

本文由 asdqp233 编写。

安装Mod加载器

当你在安装新的游戏客户端时候,会看到其中有forge,liteloader,fabric这3个mod加载器可供选择。

mod_loader

当你使用1.14及以上的游戏版本时,推荐使用fabric,1.14以下的版本推荐使用forge。liteloader只适用1.12及以前的版本(目前已停更)。

注意:liteloaderforge是兼容的(Forge较新版本和LiteLoader较老版本可能会出现不兼容),但fabricforge不兼容!

选择完合适的mod加载器之后就可以点击右下角的安装继续进行安装。

注意:如果选择fabric,那么建议你同时选择fabric api

安装Mod

自动安装

Forge Mod

HMCL内置了Curseforge源和 Modrinth源的搜索和下载功能,目前已支持中文搜索(匹配结果不一定准确)。点开mod下载页面,最上方会显示当前mod需要的前置mod(如果有的话),以及mod支持的全部版本,请根据你当前安装的游戏版本选择恰当的版本。

注意:请区分Forge ModFabric Mod,大部分mod在文件名中会注明,请不要选择错误,否则mod无法被正确加载。

mod_install

Fabric Mod

Fabric Mod 的安装和Forge Mod的安装类似,参照上文。

注意:所有的Fabric Mod都需要Fabric API(前置mod)在安装Mod加载器时候如果没有选择,请先安装Fabric API(安装方法和普通mod安装方法相同),否则Fabric Mod无法被加载!

LiteLoader Mod

LiteLoader Mod安装和Forge Mod的安装类似,参照上文。

注意:LiteLoader 只能加载文件后缀为litemod的模组,Forge Mod修改后缀后LiteLoader无法检测。

手动安装

一般的Mod文件后缀为jar或者litemod

将这个jar文件复制到\.minecraft\mods文件夹中即可 (没有这个文件夹就自己新建一个)。如果开了版本隔离,那么文件夹是\.minecraft\version\<客户端名称>/mods

或者在HMCL中游戏管理页面—模组管理页面点击添加模组或直接将文件拖入启动器窗口。

mod_add

安装Mod后游戏报错/无法启动

造成游戏报错的原因有很多,比如mod之间不兼容,fabric api的版本过高,缺少前置mod等等。

  1. 新版本的HMCL拥有错误分析功能,可以根据HMCL的提示来排查原因。

  2. 也可以使用二分法来解决——每次加入/删除一半的mod,挨个排除,直到找到导致游戏报错的mod为止。

  3. 如果你的能力很优秀,也可以直接查看游戏日志来找出问题的原因。

  4. 如果无法理解日志内容,那么请将/.minecraft/crash-reports和/.minecraft/log文件夹打包发给其他人寻求帮助。

Updated: